Aconex - EU1 Service issue impacting Reports
Incident Report for Oracle Aconex
Resolved
This incident has been resolved.
Posted Apr 20, 2024 - 02:19 UTC
Investigating
We are currently investigating this issue.
Posted Apr 20, 2024 - 01:21 UTC
This incident affected: Europe (EU1) (Insights).